Rhapsody10.0.3Windows-X64._iFix002.zip - Login to get access
| Category | APAR ID/ Defect ID | Summary |
| Extendibility/Rule Composer and Player | DT474554 | A "Rules composer tool is not installed" error occurs when using the code generation feature on CL. |
| Export-Import Integrations/RHP XMI | DT471300 | Avoid displaying a pop-up when adding a pin with API without matching argument in the CallOperation yet |
| Extendibility/Java API (COM) | DT471905 | Unable to use redefinitions on SysML Ports via API. |
| IDE Integrations/Visual Studio Integration | DT472987 | Rhapsody 10.0.3 iFix001 integration does not work with Visual Studio 2022 |
| Modeling - General | DT471438 | The persistsAs field is case sensitive for the purposes of sandbox monitoring |
| Profiles - General | DT496234 | FMU Generation failed exception during export |
| RHP Graphic Editors/Table Matrix | DT452956 | TableLayout crashes when modifying blocks shown within the table. |
| Category | APAR ID/ Defect ID | Summary |
| XMI | DT470656 | An experiencing character encoding issue in 10.0.3 with XMI Toolkit. |
| Modeling - General | 291188 | Element deletion in Load On Demand should be configurable. Either allow deletion or not allowed deletion. |
| Rhapsody Misc | 291149 | Folders created for (U) elements when search for element in LoD mode |
Most of the following steps refer to the Share directory as being a subdirectory of the main Rhapsody installation directory. If you are performingâ¯the "split" installation of Rhapsody,â¯then the Share directory is created in the user's home directory, which is C:\Users\<username>\IBM\Rhapsody. If you are installing it for all the users, the Share directory is created in C:\ProgramData\IBM\Rhapsody.
Verify that the system environment variable by the name TELELOGIC_LICENSE_FILE exists and points to the location of a valid license server or file. For more information about license management, see managing licenses.
Installing this interim fix replaces existing log4j.properties file with new log4j2.xml file. You might want to take backup of all of your log4j.properties files before you execute the following steps. For more information about log4j related changes, see IBM support.
It is not possible to uninstall only the iFix. To uninstall the iFix, you must:
Session info: No active session